Skip to main content



1 comment

  • Samantha

    Let's make sure your Charm Settings are allowing your Charms to be automatically equipped. Click anywhere on the right side of the screen where your active Charms are displayed to open your Charm Manager. Next, click on your Charm Settings and make sure the Auto Equip Charms setting is checked.


Please sign in to leave a comment.

Powered by Zendesk